Compose Database Versions

Documenting what database versions are deployed and supported by Compose

At Compose we have a lot of databases and a lot of versions of those databases. On this page, we list the current default version - what you get if you create a new deployment of that database - and the supported versions that we currently manage. Note that we don't allow people to create new deployments with older versions.

Once new database versions are available, Compose tests them for functionality and feature compatibility within the Compose environment. There may be delays between a database release and its availability to be deployed. Urgent security or critical bug fixes may be released more quickly or more frequently as needed.

DatabaseSupported VersionsDeployable VersionsCurrent Default Version
MongoDB3.2.10, 3.2.11, 3.2.18, 3.4.10, 3.6.83.2.10, 3.2.11, 3.2.18, 3.4.10, 3.6.83.6.8
Elasticsearch5.4.2, 5.6.3, 5.6.9, 5.6.16, 6.2.2, 6.5.2, 6.6.25.6.9, 5.6.16, 6.5.2, 6.6.26.5.2
PostgreSQL9.4.19, 9.4.20, 9.4.21; 9.5.14, 9.5.15, 9.5.16; 9.6.10, 9.6.11, 9.6.129.4.20, 9.4.21; 9.5.15, 9.5.16; 9.6.11, 9.6.129.6.11
Redis3.2.12, 4.0.10, 4.0.143.2.12, 4.0.10, 4.0.144.0.10
RethinkDB2.2.4, 2.3.5, 2.3.62.3.62.3.6
RabbitMQ3.5.6, 3.6.5, 3.6.9, 3.6.11, 3.6.14, 3.7.5, 3.7.93.6.14, 3.7.93.7.9
etcd 33.2.1, 3.2.2, 3.2.4, 3.2.5, 3.2.7, 3.2.9, 3.2.10, 3.2.11, 3.2.13, 3.2.18, 3.3.33.2.18, 3.3.33.3.3
Scylla1.4.2, 1.6.0, 1.7.2, 1.7.5, 2.0.32.0.32.0.3
Compose for MySQL (beta)5.7.17, 5.7.19, 5.7.20, 5.7.225.7.20, 5.7.225.7.22
MongoDB Classic3.0.11, 2.6.11, 2.6.93.0.113.0.11
  • Currently no in-place upgrade for MySQL is available.
  • etcd v2 is deprecated - no new deployments after December 2017

Still Need Help?

If this article didn't solve things, summon a human and get some help!